advanced-emoji

README

GitBook Plugin: Advanced Emoji

Transforms emojis like :white_check_mark: into real emoji images using emojify.js.

Please note that this plugin only works for markdown files. All other filetypes will just be ignored, and the plugin does nothing.

Installation

You can install this plugin via npm:

$ npm install gitbook-plugin-advanced-emoji

Be sure to activate the option from the book.json file:

{
    "plugins" : ["advanced-emoji"]
}

Then run gitbook install followed by either gitbook serve or gitbook build

Using Ignore Flags

If you want for example occurences of emojis not replaced you will need to wrap them in the following comments.

<!-- ignore:advanced-emoji:start -->
:white_check_mark:
<!-- ignore:advanced-emoji:end -->

You can even set the ignores around a codeblock or more lines.

This is a text

<!-- ignore:advanced-emoji:start -->
'''
Check the Code
Code ... :white_check_mark:
'''
<!-- ignore:advanced-emoji:end -->

foo

Versions

  • GitBook will automatically install the right version of the plugin
    • master branch is for GitBook v3.x and plugin version is 0.2.x
    • gitbook_v2 branch is for GitBook v2.x and plugin version is 0.1.x

Building a PDF

You can see the Branch pdf-test-book on how to use the plugin when building a PDF.

License

Configuration

Setting Description Type Allowed values
embedEmojis Boolean
-

Plugin

Shows the common emojis used on GitHub

https://github.com/codeclou/gitbook-plugin-advanced-emoji


Latest: 0.2.2

0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.0.6, 0.1.0, 0.1.1, 0.1.2, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.2.0, 0.2.1, 0.2.2,

Requirements

GitBook
0.0.1 >=0.3.4
0.1.9 >=2.5.0
0.2.2 >=3.0.0-pre.0

Maintainers

Open on NPM