rss

README

gitbook-plugin-rss

NPM version Dependency Status

RSS for your gitbook

Generate a RSS feed and display link to feed in your gitbook:

image

It's very useful for books which get update several times a month. If you wanna notify readers about updates, just use this plugin.

Install

npm install --save gitbook-plugin-rss

Usage

Add it to your book.json with a basic configuration:

{
  "plugins": [ "rss" ],
  "pluginsConfig": {
    "rss": {
      "title": "My amazing book",
      "description": "This is the best book ever.",
      "author": "Denys Dovhan",
      "site_url": "http://book.org/",
      "managingEditor": "writer@book.org (Denys Dovhan)",
      "webMaster": "webmaster@book.org (Denys Dovhan)",
      "categories": [
        "awesome",
        "book",
        "gitbook"
      ]
    }
  }
}

API

  • title (required string) — Title of your site or feed
  • site_url (required url string) — Url to the site that the feed is for.
  • feed_url (required url string) — Url to the rss feed.
  • description (optional string) — A short description of the feed.
  • generator (optional string) — Feed generator.
  • image_url (optional url string) — Small image for feed readers to use.
  • managingEditor (optional string) — Who manages content in this feed.
  • webMaster (optional string) — Who manages feed availability and technical support.
  • categories (optional array of strings) — One or more categories this feed belongs to.
  • copyright (optional string) — Copyright information for this feed.
  • language (optional string) — The language of the content of this feed.

License

MIT © Denys Dovhan

Configuration

Setting Description Type Allowed values
categories Array
-
copyright String
-
description String
-
feed_url
required
String
-
generator String
-
image_url String
-
language String
-
managingEditor String
-
site_url
required
String
-
title
required
String
-
webMaster String
-

Plugin


Latest: 3.0.2

1.0.0, 1.0.1, 1.0.2, 1.1.0, 2.0.0, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 3.0.0, 3.0.1, 3.0.2,

Requirements

GitBook
2.1.5 >=2.5.0
3.0.2 >=3.2.0

Maintainers

Open on NPM