theme-helpcenter

README

GitBook FAQ Theme

Theme for using GitBook to publish an FAQ or Knowledge Base. This theme works perfectly with search plugins (as the default one or algolia).

Usage

This theme requires GitBook version 3 or later.

Add the theme to your book's configuration (book.json):

{
    "plugins": [
        "theme-faq",
        "-fontsettings",
        "-sharing"
    ]
}

NOTE theme-faq is not compatible with plugins that modify the toolbar (since there is no toolbar). Embedded search will not work as a result. This includes the default plugins fontsettings and sharing that need to be disabled explicitly (add a minus flag "-" before each plugin parameter).

Add relations between articles

Suggestions for other articles can be shown at the bottom of an article.

Relationships are specified in the YAML frontmatter of a page:

---
related:
    - some/other/page.md
    - another_related_article.md

---

Content of my article!

Add logo to header

Extend the theme by creating a file _layouts/website/page.html in your book with:

{% extends template.self %}

{% block faq_header_brand %}
<img src="https://mywebsite.com/logo.png" height="30" />
{% endblock %}

Extend the theme by creating a file _layouts/website/page.html in your book with:

{% extends template.self %}

{% block faq_menu %}
<ul class="nav navbar-nav navbar-right">
    <li><a href="#">Contact us</a></li>
    <li><a href="#">Return to SuperWebsite</a></li>
</ul>
{% endblock %}

Add a short description on the home page

The content of your README is used as a short description for the home page of your FAQ.

If you wish use a specific file for this description instead of your project's README, you can configure your book.json to do so:

{
  "structure": {
     "readme": "home-page-description.md"
  }
}

Plugin

Theme for using GitBook as a FAQ or Knowledge base

https://github.com/GitbookIO/theme-faq#readme


Latest: 1.2.54

1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 1.2.10, 1.2.11, 1.2.12, 1.2.13, 1.2.14, 1.2.15, 1.2.16, 1.2.17, 1.2.18, 1.2.19, 1.2.20, 1.2.21, 1.2.22, 1.2.23, 1.2.24, 1.2.25, 1.2.26, 1.2.27, 1.2.28, 1.2.29, 1.2.30, 1.2.31, 1.2.32, 1.2.33, 1.2.34, 1.2.35, 1.2.36, 1.2.37, 1.2.38, 1.2.39, 1.2.40, 1.2.41, 1.2.42, 1.2.47, 1.2.48, 1.2.49, 1.2.50, 1.2.51, 1.2.52, 1.2.53, 1.2.54,

Requirements

GitBook
1.2.54 >=3.0.0-pre.10

Maintainers

Open on NPM